Skip to content

Understanding GUI

Supported Python versions

Taipy requires Python 3.8 or newer.

Welcome to the Tutorial for using Taipy frontend. This guide will demonstrate how to utilize Taipy to build an interactive web application.

GUI application

Taipy aims to simplify web application development:

  • Accelerates application building.

  • Streamlines management of variables and events.

  • Offers intuitive visualization using Markdown syntax.

In each part of the "Tutorial" we'll emphasize the basic principles of Taipy. It's important to note that each step builds on the code from the previous one. By the end of the final step, you'll be equipped with the ability to create your own Taipy application.

Before we begin

Taipy package requires Python 3.8 or newer;

$ pip install taipy

Once you finish step 5, the application will include a Natural Language Processing (NLP) algorithm for demonstration purposes. Note that this algorithm is compatible only with Python versions 3.8 to 3.10. To incorporate this NLP feature, you'll need to install Transformers and Torch. However, if you prefer, you can proceed with the tutorial guide without using this algorithm.

$ pip install torch
$ pip install transformers

Info

pip install taipy is the preferred method to install the latest stable version of Taipy.

If you don't have pip installed, this Python installation guide can guide you through the process.

Using Notebooks

This Tutorial is for Python scripts (.py) only. If you want to use Jupyter Notebooks, download this notebook.

Taipy Studio

Taipy Studio is a VS Code extension that provides an auto-completion of Taipy visual elements. Creating a Taipy application can be done more easily and quickly through Taipy Studio.

So, without further delay, let's begin to code!

Steps

  1. First Web page

  2. Visual elements

  3. Interaction

  4. Charts

  5. Python expression in properties

  6. Page layout

  7. Multi-pages, navbars, and menus